nixos-configs/ci.nix
matt1432 cab5bfa648
All checks were successful
Discord / discord commits (push) Has been skipped
refactor: reduce amount of IFDs
2024-06-10 22:57:20 -04:00

15 lines
420 B
Nix

# CI: https://github.com/Mic92/dotfiles/blob/c2f538934d67417941f83d8bb65b8263c43d32ca/flake.nix#L168
{
system,
pkgs,
self,
}: let
inherit (pkgs.lib) filterAttrs mapAttrs' nameValuePair;
nixosMachines =
mapAttrs'
(name: config: nameValuePair "nixos-${name}" config.config.system.build.toplevel)
((filterAttrs (_: config: config.pkgs.system == system)) self.nixosConfigurations);
in
nixosMachines