nixos-configs/configurations/homie/modules/home-assistant/docs/functions.nix
matt1432 6ca0d7248b
All checks were successful
Discord / discord commits (push) Has been skipped
refactor: rename some flake attr directories
2024-12-16 15:51:41 -05:00

26 lines
583 B
Nix

# I use nix2yaml from ../default.nix to convert this to YAML and place it in the functions of extended_ollama_conversation
[
{
spec = {
name = "get_attributes";
description = "Get attributes of any home assistant entity";
parameters = {
type = "object";
properties = {
entity_id = {
type = "string";
description = "entity_id";
};
};
required = ["entity_id"];
};
};
function = {
type = "template";
value_template = "{{ states[entity_id] }}";
};
}
]