nixos-configs/devices/cluster/modules/nfs-client.nix
matt1432 141299e3ad
All checks were successful
Discord / discord commits (push) Successful in 26s
feat(servers): use my custom pacemaker module
2024-01-26 14:28:42 -05:00

31 lines
626 B
Nix

{pkgs, ...}: {
# NFS client setup
services.rpcbind.enable = true;
boot.supportedFilesystems = ["nfs"];
environment.systemPackages = with pkgs; [nfs-utils];
systemd.mounts = let
host = "10.0.0.249";
in [
{
type = "nfs";
mountConfig = {
Options = "noatime";
};
what = "${host}:/caddy";
where = "/var/lib/caddy";
requiredBy = ["caddy.service"];
}
{
type = "nfs";
mountConfig = {
Options = "noatime";
};
what = "${host}:/headscale";
where = "/var/lib/headscale";
requiredBy = ["headscale.service"];
}
];
}