nixos-configs/devices/homie/modules/home-assistant/netdaemon/package.nix
matt1432 fa29886b8a
All checks were successful
Discord / discord commits (push) Has been skipped
refactor(netd): don't count auto-gen code in repo
2024-10-21 02:48:43 -04:00

41 lines
972 B
Nix

{
lib,
buildDotnetModule,
dotnetCorePackages,
}: let
inherit (lib) any hasInfix hasSuffix removeSuffix;
srcDirs = ["apps"];
srcPatterns = [".cs" ".csproj" ".json" ".version" "HomeAssistantGenerated"];
pname = "netdaemon-config";
in
buildDotnetModule {
inherit pname;
version = removeSuffix "\n" (builtins.readFile ./.version);
src = builtins.path {
name = "netdaemon-src";
path = ./.;
filter = file: type:
(type == "directory" && any (s: hasInfix s file) srcDirs)
|| any (s: hasSuffix s file) srcPatterns;
};
preBuild = ''
mv HomeAssistantGenerated HomeAssistantGenerated.cs
'';
projectFile = "netdaemon.csproj";
nugetDeps = ./deps.nix;
dotnet-sdk = dotnetCorePackages.sdk_8_0;
dotnet-runtime = dotnetCorePackages.runtime_8_0;
executables = [];
postFixup = ''
cp -r $out/lib/${pname} $netdaemonConfig
'';
outputs = ["out" "netdaemonConfig"];
}