nixos-configs/devices/oksys/default.nix
matt1432 a4fe150167
All checks were successful
Discord / discord commits (push) Has been skipped
chore: update flake.lock
2024-02-21 00:20:41 -05:00

46 lines
769 B
Nix

# Not currently operational
{config, ...}: let
inherit (config.vars) mainUser hostName;
in {
imports = [
./hardware-configuration.nix
../../modules/sshd.nix
../../modules/tailscale.nix
./modules/remote-builder.nix
];
vars = {
mainUser = "matt";
hostName = "oksys";
neovimIde = false;
};
users.users.${mainUser} = {
isNormalUser = true;
extraGroups = [
"wheel"
"adm"
];
};
home-manager.users.${mainUser} = {
imports = [];
# No touchy
home.stateVersion = "24.05";
};
networking = {
inherit hostName;
resolvconf.enable = true;
firewall.enable = false;
};
# Set your time zone.
time.timeZone = "America/Montreal";
# No touchy
system.stateVersion = "24.05";
}