nixos-configs/modules/desktop/environment/home/hyprexpo.nix
matt1432 0f4f94a772
All checks were successful
Discord / discord commits (push) Has been skipped
chore: update sources
Flake Inputs:
    • Updated input 'home-manager':
        'github:nix-community/home-manager' (2024-12-21) rev: f342df3ad938f205a913973b832f52c12546aac6
      → 'github:nix-community/home-manager' (2024-12-22) rev: 1f74238a4c8e534a1b6be72cb5153043071ffd17

    • Updated input 'hyprland':
        'github:hyprwm/Hyprland' (2024-12-21) rev: 57921d7dbd1b87a9474f609cb9cd30e6174027cd
      → 'github:hyprwm/Hyprland' (2024-12-22) rev: 1830296df3515222bf0f03b90822e3b23e74b775

    • Updated input 'hyprland-plugins':
        'github:hyprwm/hyprland-plugins' (2024-12-21) rev: 067bbc9eaba8f5b95ec69bfe91fe699a854734a5
      → 'github:hyprwm/hyprland-plugins' (2024-12-22) rev: 859b9cd371b4e1bf1043cedc8ab6c514e13ab358

    • Updated input 'jellyfin-flake':
        'github:matt1432/nixos-jellyfin' (2024-12-22) rev: 331187dbe039fa4505a0f03af4972b45a770c9bb
      → 'github:matt1432/nixos-jellyfin' (2024-12-22) rev: 4349d92771f92ab215630e9d2f4a5c2ae3378acc

    • Updated input 'nix-gaming':
        'github:fufexan/nix-gaming' (2024-12-21) rev: d767a7410d7fce228e15429eac2964153a04e26e
      → 'github:fufexan/nix-gaming' (2024-12-22) rev: e45e2276facb9218c119e68c45efd2f9e79d292d

    • Updated input 'nix-index-db':
        'github:Mic92/nix-index-database' (2024-12-15) rev: 311d6cf3ad3f56cb051ffab1f480b2909b3f754d
      → 'github:Mic92/nix-index-database' (2024-12-22) rev: d583b2d142f0428313df099f4a2dcf2a0496aa78

    • Updated input 'nixpkgs':
        'github:NixOS/nixpkgs' (2024-12-17) rev: d3c42f187194c26d9f0309a8ecc469d6c878ce33
      → 'github:NixOS/nixpkgs' (2024-12-19) rev: d70bd19e0a38ad4790d3913bf08fcbfc9eeca507

    • Updated input 'nixpkgs-wayland':
        'github:nix-community/nixpkgs-wayland' (2024-12-18) rev: 13cd8a5a5c17fcee8d6398a7c0fcc78f4cc31535
      → 'github:nix-community/nixpkgs-wayland' (2024-12-22) rev: 8988b0603fed7e3d303718328cf4cd8dd137575e

    • Updated input 'spotifyplus-src':
        'github:thlucas1/homeassistantcomponent_spotifyplus' (2024-12-20) rev: cd3973be9a8798038ab07eb68c38af342477b485
      → 'github:thlucas1/homeassistantcomponent_spotifyplus' (2024-12-21) rev: 5b5db363a128f12fd62ebdad79d0c50f14923fc6

    • Updated input 'tuya-local-src':
        'github:make-all/tuya-local' (2024-12-21) rev: 17b14effb7a04416e4b7a81fe5070d90fc2421b0
      → 'github:make-all/tuya-local' (2024-12-22) rev: 02accfd1f41e99706f184c02cc592ddb6864d14c

nix-update executions:
    homepage: 0.10.1 -> 0.10.2
2024-12-22 16:23:18 -05:00

35 lines
972 B
Nix

self: {pkgs, ...}: let
inherit (self.lib.hypr) mkBind;
in {
config = {
wayland.windowManager.hyprland = {
plugins = [self.inputs.hyprland-plugins.packages.${pkgs.system}.hyprexpo];
settings = {
plugin.hyprexpo = {
columns = 3;
gap_size = 5;
bg_col = "rgb(111111)";
workspace_method = "center current"; # [center/first] [workspace] e.g. first 1 or center m+1
enable_gesture = true; # laptop touchpad
gesture_fingers = 3;
gesture_distance = 300; # how far is the "max"
gesture_positive = true; # positive = swipe down. Negative = swipe up.
};
bind = [
(mkBind {
modifier = "ALT";
key = "tab";
dispatcher = "hyprexpo:expo";
command = "toggle"; # can be: toggle, off/disable or on/enable
})
];
};
};
};
# For accurate stack trace
_file = ./hyprexpo.nix;
}